Chrome 44 quebrando wordpress em toda parte

Alguns sites wordpress quebraram na nova versão do navegador Chrome lançada ontem. O que acontece é que o browser passou a informar que aquela página dá suporte a https, fazendo com que algumas chamadas a CSS, scripts e etc. apontassem para o arquivo com o protocolo errado.

Uma nova versão do navegador está programada para ser lançada no dia 27, mas até lá você pode editar o arquivo wp-includes/functions.php, localizando a função is_ssl() editando isso:

if ( '1' == $_SERVER['HTTPS'] )
return true;

para isso:

// if ( '1' == $_SERVER['HTTPS'] )
// return true;

Mais detalhes aqui: https://ma.ttias.be/chrome-44-sending-https-header-by-mistake-breaking-web-applications-everywhere/

Tags:

Comentários